Fix the fact that we can't bump RAM quotas above 2048M
[invirt/packages/invirt-xen-config.git] / debian / changelog
1 invirt-xen-config (0.0.59) unstable; urgency=low
2
3   * Fix the fact that we can't bump RAM quotas above 2048M
4     (and acknowledge the reality that 2048M really isn't the rarest
5     thing to need these days)
6
7   Quoting from history:
8
9   """
10      invirt-xen-config (0.0.15) unstable; urgency=low
11
12        * Set the max memory to a really high number so we can bump it for users
13        * Pass the correct networking device to vif-invirtroute
14
15       -- Evan Broder <broder@mit.edu>  Fri, 14 Nov 2008 00:03:47 -0500
16   """
17
18   i,i "640K ought to be enough for anyone."
19
20  -- Mitchell Berger <mitchb@mit.edu>  Tue, 23 Jul 2019 18:50:00 -0400
21
22 invirt-xen-config (0.0.58) unstable; urgency=low
23
24   * Support kickstart-based Fedora autoinstalls.
25
26  -- Quentin Smith <quentin@mit.edu>  Sat, 15 Jun 2019 20:59:54 -0400
27
28 invirt-xen-config (0.0.57) unstable; urgency=low
29
30   * invirt-database: Fix the autoinstall logic so that if we've
31     increased the memory temporarily for the autoinstall above
32     the machine's database setting, we also bring maxmem up to
33     the same level.  Otherwise the machine doesn't turn on
34     because it's requesting to start with more memory than maxmem,
35     and this failure mode is silent to the user.
36
37  -- Mitchell Berger <mitchb@mit.edu>  Sat, 02 Feb 2019 16:52:00 -0500
38
39 invirt-xen-config (0.0.56) unstable; urgency=low
40
41   * vif-invirtroute: Kill arpspoof with SIGKILL when we're done.  The
42     version in this distro (which is the latest beta from the
43     unmaintained upstream) tries to "clean up" when you normally
44     terminate it.  This involves trying to perform an ARP lookup
45     without interfering to see what the MAC should've been and then
46     sending replies for that.  This appears to cause a race depending
47     on whether the entry for the machine's old domain (if it's being
48     rebooted) is listed as <incomplete> in the ARP table or is totally
49     flushed.  If you lose the race, it sends further gratuitous ARPs
50     telling the router that your MAC is all-zeros because of a bug
51     where it fails to check for an incomplete ARP entry.  This is
52     believed to cause the bug that has plagued XVM for years where
53     you sometimes lose off-network connectivity on reboot.
54
55  -- Mitchell Berger <mitchb@mit.edu>  Mon, 25 Jun 2018 22:04:00 -0400
56
57 invirt-xen-config (0.0.55) unstable; urgency=low
58
59   * invirt-database: bump up autoinstall memory to make modern releases
60     work again.
61
62  -- Mitchell Berger <mitchb@mit.edu>  Fri, 01 Jun 2018 02:17:00 -0400
63
64 invirt-xen-config (0.0.54) unstable; urgency=low
65
66   * invirt-database: handle several possible actions to take with an
67     "other" set of network parameters.  Renumber a machine by swapping
68     the sets of netparams, DNAT from an old address by passing through
69     additional parameters to vif-invirtroute, and teardown an IP
70     transition by clearing all the "other" values.  Also, use the
71     netmask and gateway for the VM when autoinstalling, rather than
72     parameters from the global cluster configuration.
73   * vif-invirtroute: if there is an "other" IP address, DNAT it to the
74     primary IP, set up routing to get it to the VM, and arp for it.
75     Also, cut out the nonsense with backgrounding arpspoof, sleeping, and
76     killing it; we have the technology for 'timeout'.  Finally, don't
77     pass a "src" argument to "ip route del" to ensure a match even if
78     the host's "main IP" has changed and caused the route to be inserted
79     with a different src.
80   * templatize-xend-config: explicitly turn on the relocation server
81   * qemu-ifup.invirt: make HVMs work and not only if your eth0 just happens
82     to have an IPv4 network address sitting on it
83
84  -- Mitchell Berger <mitchb@mit.edu>  Sun, 27 May 2018 01:45:00 -0400
85
86 invirt-xen-config (0.0.53) unstable; urgency=low
87
88   * Fix machine UUID assignment after SQLAlchemy started returning Unicode
89     objects.
90
91  -- Quentin Smith <quentin@mit.edu>  Mon, 06 Jan 2014 22:02:11 -0500
92
93 invirt-xen-config (0.0.52) UNRELEASED; urgency=low
94
95   * Fix PVHVM networking
96
97  -- Adam Glasgall <glasgall@mit.edu>  Mon, 02 Sep 2013 21:16:01 -0400
98
99 invirt-xen-config (0.0.51) unstable; urgency=low
100
101   * Fixed code for NIC model options.
102
103  -- Steven Valdez <dvorak42@mit.edu>  Wed, 31 Jul 2013 22:28:39 -0400
104
105 invirt-xen-config (0.0.50) unstable; urgency=low
106
107   * Adding NIC model option to DB.
108
109  -- Steven Valdez <dvorak42@mit.edu>  Fri, 26 Jul 2013 22:28:47 -0400
110
111 invirt-xen-config (0.0.49) precise; urgency=low
112
113   * Change HVM emulated network card to pcnet, because the emulated
114     realtek hardware is as bad as the real realtek hardware.
115
116  -- Adam Glasgall <glasgall@mit.edu>  Tue, 23 Jul 2013 02:52:06 -0400
117
118 invirt-xen-config (0.0.48) precise; urgency=low
119
120   * Disable PVHVM for now until we figure out the best way to do it
121
122  -- Adam Glasgall <glasgall@mit.edu>  Mon, 22 Jul 2013 01:08:40 -0400
123
124 invirt-xen-config (0.0.47) unstable; urgency=low
125
126   * Blame glasgall for the wasted version number.
127
128  -- Quentin Smith <quentin@mit.edu>  Sun, 21 Jul 2013 14:55:00 -0400
129
130 invirt-xen-config (0.0.46) unstable; urgency=low
131
132   * Non-hotplug events apparently also use vif-setup.
133
134  -- Quentin Smith <quentin@mit.edu>  Sun, 21 Jul 2013 14:49:54 -0400
135
136 invirt-xen-config (0.0.45) unstable; urgency=low
137
138   * Neuter vif-setup (from xl, perhaps?)
139   * Update vif-invirtroute for Xen 4's scripts.
140
141  -- Quentin Smith <quentin@mit.edu>  Sun, 21 Jul 2013 14:28:58 -0400
142
143 invirt-xen-config (0.0.44) unstable; urgency=low
144
145   * Disable populate-on-demand for HVMs.
146
147  -- Quentin Smith <quentin@mit.edu>  Sun, 21 Jul 2013 13:14:53 -0400
148
149 invirt-xen-config (0.0.43+nmu1) precise; urgency=low
150
151   * Use config-package-dev.
152
153  -- Alexander Chernyakhovsky <achernya@mit.edu>  Sun, 21 Jul 2013 12:48:47 -0400
154
155 invirt-xen-config (0.0.43) precise; urgency=low
156
157   * fix the diversion too.
158
159  -- Adam Glasgall <glasgall@mit.edu>  Sun, 21 Jul 2013 01:14:41 -0400
160
161 invirt-xen-config (0.0.42) precise; urgency=low
162
163   * qemu-ifup moved from /etc/xen to /etc/xen/scripts
164
165  -- Adam Glasgall <glasgall@mit.edu>  Sun, 21 Jul 2013 01:06:27 -0400
166
167 invirt-xen-config (0.0.41) precise; urgency=low
168
169   * no-change rebuild
170
171  -- Adam Glasgall <glasgall@mit.edu>  Sat, 20 Jul 2013 16:54:56 -0400
172
173 invirt-xen-config (0.0.40) precise; urgency=low
174
175   * Updating version for precise.
176
177  -- Steven Valdez <dvorak42@mit.edu>  Sat, 20 Jul 2013 16:46:47 -0400
178
179 invirt-xen-config (0.0.39) unstable; urgency=low
180
181   * Treat config.hosts.internal_ips as an array
182
183  -- Peter Iannucci <iannucci@mit.edu>  Mon, 01 Jul 2013 21:51:00 -0400
184
185 invirt-xen-config (0.0.38~glasgall15) precise; urgency=low
186
187   * Teach qemu-dm-invirt that /usr/lib/xen moved to /usr/lib/xen-4.1
188
189  -- Adam Glasgall <glasgall@mit.edu>  Thu, 06 Jun 2013 21:36:37 -0400
190
191 invirt-xen-config (0.0.38~glasgall14achernya1) precise; urgency=low
192
193   * Switch to dh7
194   * Bump standards version
195
196  -- Alexander Chernyakhovsky <achernya@mit.edu>  Fri, 31 May 2013 21:16:20 -0400
197
198 invirt-xen-config (0.0.38~glasgall14) precise; urgency=low
199
200   * /usr/lib/xen moved to /usr/lib/xen-4.1. teach invirt-database this.
201
202  -- Adam Glasgall <glasgall@mit.edu>  Wed, 08 May 2013 00:06:25 -0400
203
204 invirt-xen-config (0.0.38~glasgall13) precise; urgency=low
205
206   * Undo enabling network-bridge; we want to manage our own bridge config
207     now. Oh, irony.
208
209  -- Adam Glasgall <glasgall@mit.edu>  Mon, 06 May 2013 19:14:41 -0400
210
211 invirt-xen-config (0.0.38~glasgall12) precise; urgency=low
212
213   * xm was expecting a string and was getting a unistring for machine
214     name, which resulted in the VM name always being
215     'invirt-database'. Use passed-in machine_name instead, since that will
216     be a string. IBTSOCS.
217
218  -- Adam Glasgall <glasgall@mit.edu>  Mon, 06 May 2013 19:14:23 -0400
219
220 invirt-xen-config (0.0.38~glasgall11) precise; urgency=low
221
222   * Add dependency on ethtool.
223
224  -- Adam Glasgall <glasgall@mit.edu>  Fri, 26 Apr 2013 22:36:10 -0400
225
226 invirt-xen-config (0.0.38~glasgall10) precise; urgency=low
227
228   * SQLAlchemy API updates in invirt-database xen config
229
230  -- Adam Glasgall <glasgall@mit.edu>  Fri, 26 Apr 2013 21:14:25 -0400
231
232 invirt-xen-config (0.0.38~glasgall9) precise; urgency=low
233
234   * _really_  correct regexp this time.
235
236  -- Adam Glasgall <glasgall@mit.edu>  Sat, 13 Apr 2013 17:57:11 -0400
237
238 invirt-xen-config (0.0.38~glasgall8) precise; urgency=low
239
240   * fix typo in regexp
241
242  -- Adam Glasgall <glasgall@mit.edu>  Sat, 13 Apr 2013 17:49:08 -0400
243
244 invirt-xen-config (0.0.38~glasgall7) precise; urgency=low
245
246   * Correct regexp in s/// over xend-config.sxp
247
248  -- Adam Glasgall <glasgall@mit.edu>  Sat, 13 Apr 2013 17:46:43 -0400
249
250 invirt-xen-config (0.0.38~glasgall6) precise; urgency=low
251
252   * Enable network-bridge in xend-config.sxp, since Precise doesn't by 
253     default anymore.
254
255  -- Adam Glasgall <glasgall@mit.edu>  Sat, 13 Apr 2013 17:40:33 -0400
256
257 invirt-xen-config (0.0.38~glasgall5) precise; urgency=low
258
259   * s/// out the "${XEN_CONFIG_DIR}" reference that was making mako choke
260
261  -- Adam Glasgall <glasgall@mit.edu>  Sun, 24 Mar 2013 20:31:31 -0400
262
263 invirt-xen-config (0.0.38~glasgall4) precise; urgency=low
264
265   * Oops, no, we don't actually want to uninstall grub. Depend on grub-pc
266     instead.
267
268  -- Adam Glasgall <glasgall@mit.edu>  Sun, 24 Mar 2013 17:49:24 -0400
269
270 invirt-xen-config (0.0.38~glasgall3) precise; urgency=low
271
272   * ubuntu-xen-server bit the dust several releases ago. replace it by
273     explicitly listing the xen bits we need in Depends.
274
275  -- Adam Glasgall <glasgall@mit.edu>  Sun, 24 Mar 2013 17:44:24 -0400
276
277 invirt-xen-config (0.0.38~glasgall2) precise; urgency=low
278
279   * Bump xen-utils dependency
280   * Update xend-config.sxp transformer for newer default config
281
282  -- Adam Glasgall <glasgall@mit.edu>  Sun, 24 Mar 2013 17:37:05 -0400
283
284 invirt-xen-config (0.0.38~glasgall1) precise; urgency=low
285
286   * Bump version for precise
287
288  -- Adam Glasgall <glasgall@mit.edu>  Thu, 21 Mar 2013 23:24:57 -0700
289
290 invirt-xen-config (0.0.37) unstable; urgency=low
291
292   * Support multiple NICs on HVMs.
293
294  -- Mitchell Berger <mitchb@mit.edu>  Sat, 29 Oct 2011 21:53:00 -0400
295
296 invirt-xen-config (0.0.36) unstable; urgency=low
297
298   * Version bump to recover from invirtibuilder version error. No changes.
299
300  -- Joshua Oreman <oremanj@mit.edu>  Tue, 26 Apr 2011 16:30:22 -0400
301
302 invirt-xen-config (0.0.33) unstable; urgency=low
303
304   * Explicitly disable proxy_arp on the "all" interface; it seems to be
305     enabled on bootup if we don't.
306
307  -- Joshua Oreman <oremanj@mit.edu>  Tue, 26 Apr 2011 16:12:52 -0400
308
309 invirt-xen-config (0.0.32) unstable; urgency=low
310
311   * Don't enable proxy arp on every interface, just the public one (fixes
312     problems with reachability on the backend network!)
313
314  -- Quentin Smith <quentin@mit.edu>  Wed, 09 Mar 2011 18:18:06 -0500
315
316 invirt-xen-config (0.0.31) unstable; urgency=low
317
318   * Only run arpspoof when NICs are brought online (this potentially fixes
319     a race condition that occurs when migrating VMs)
320   * Remove the advertised gso-tcpv4 feature from VIFs which causes the
321     guest to incorrectly believe that Xen supports TCP segmentation
322     offload. This supercedes our previous fix of disabling TSO in guest
323     kernels.
324
325  -- Quentin Smith <quentin@mit.edu>  Mon, 27 Dec 2010 01:19:58 -0500
326
327 invirt-xen-config (0.0.30) unstable; urgency=low
328
329   * Support debian-installer based autoinstallation.
330
331  -- Quentin Smith <quentin@mit.edu>  Sun, 26 Dec 2010 17:10:54 -0500
332
333 invirt-xen-config (0.0.29) unstable; urgency=low
334
335   * Merged in r2821,2824,2827 from hvirt branch.
336
337  -- Greg Brockman <gdb@mit.edu>  Sun, 31 Jan 2010 18:44:53 -0500
338
339 invirt-xen-config (0.0.28) unstable; urgency=low
340
341   * Restarting xend is just a *really bad* idae.
342
343  -- Evan Broder <broder@mit.edu>  Tue, 26 Jan 2010 23:32:47 -0500
344
345 invirt-xen-config (0.0.27) unstable; urgency=low
346
347   [ Greg Brockman ]
348   * Nuked the pinning of libxen3
349   * Changed xen.network -> xen
350
351   [ Evan Broder ]
352   * Don't try to start sysvms in the invirt-xen-config init script. The
353     code has never been reliable.
354   * Don't create iptables rules in vif-invirtroute - they don't do anything.
355   * For simplicity, and because we've never used it, tear the IPv6
356     "support" out of vif-invirtroute.
357
358   [ Quentin Smith ]
359   * Increase dom0's weight to improve IO performance.
360
361  -- Greg Brockman <gdb@mit.edu>  Sun, 17 Jan 2010 23:32:03 -0500
362
363 invirt-xen-config (0.0.26) unstable; urgency=low
364
365   * Kill the moocow password for the VNC server. Not setting this variable
366     causes VNC clients to not prompt for a password instead.
367
368  -- Evan Broder <broder@mit.edu>  Mon, 28 Sep 2009 21:20:21 -0400
369
370 invirt-xen-config (0.0.25) unstable; urgency=low
371
372   * Some of the autoinstallers want a lot of RAM. Give it to them.
373
374  -- Evan Broder <broder@mit.edu>  Sun, 26 Jul 2009 20:35:13 -0700
375
376 invirt-xen-config (0.0.24) unstable; urgency=low
377
378   * Prepare for a Xen 3.3 world by allowing either 3.2 or 3.3 packages.
379
380  -- Evan Broder <broder@mit.edu>  Fri, 20 Feb 2009 17:36:23 -0500
381
382 invirt-xen-config (0.0.23) unstable; urgency=low
383
384   * revert 0.0.22
385   * use run-parts --list to get a tighter set of sysvm config files
386
387  -- Greg Price <price@mit.edu>  Tue, 03 Feb 2009 00:20:03 -0500
388
389 invirt-xen-config (0.0.22) unstable; urgency=low
390
391   * Correctly calculate both the list of sysvms to boot and the list of
392     Mako templates to render in the init script.
393
394  -- Evan Broder <broder@mit.edu>  Mon, 02 Feb 2009 17:30:51 -0500
395
396 invirt-xen-config (0.0.21) unstable; urgency=low
397
398   * Move sysvms/* into xvm-prodconfig from invirt-xen-config
399   * genericize sysvm startup to glob /etc/xen/sysvms/s_*
400   * eth2 -> config.xen.network.iface
401
402  -- Greg Price <price@mit.edu>  Sat, 31 Jan 2009 18:40:20 -0500
403
404 invirt-xen-config (0.0.20) unstable; urgency=low
405
406   * Add Provides and Conflicts lines to debian/control for
407     config-package-dev
408
409  -- Evan Broder <broder@mit.edu>  Sat, 24 Jan 2009 20:16:06 -0500
410
411 invirt-xen-config (0.0.19) unstable; urgency=low
412
413   * prune tempfile, subprocess imports from invirt-database
414     (subprocess!  wow, that was a hack.  that was also over a year ago, r223.)
415
416  -- Greg Price <price@mit.edu>  Tue, 09 Dec 2008 00:25:56 -0500
417
418 invirt-xen-config (0.0.18) unstable; urgency=low
419
420   * Explicitly grab the short form of the hostname to assemble the backend
421     hostname
422
423  -- Evan Broder <broder@mit.edu>  Wed, 26 Nov 2008 01:27:07 -0500
424
425 invirt-xen-config (0.0.17) unstable; urgency=low
426
427   * Pin libxen3 to the hardy repository so it doesn't get pulled from
428     hardy-backports until we're ready to upgrade to Xen 3.3
429
430  -- Evan Broder <broder@mit.edu>  Sat, 22 Nov 2008 19:19:07 -0500
431
432 invirt-xen-config (0.0.16) unstable; urgency=low
433
434   * Pick the kernel and initrd for the autoinstaller based on the kernel
435     the dom0 is currently running
436
437  -- Evan Broder <broder@mit.edu>  Sat, 15 Nov 2008 23:45:30 -0500
438
439 invirt-xen-config (0.0.15) unstable; urgency=low
440
441   * Set the max memory to a really high number so we can bump it for users
442   * Pass the correct networking device to vif-invirtroute
443
444  -- Evan Broder <broder@mit.edu>  Fri, 14 Nov 2008 00:03:47 -0500
445
446 invirt-xen-config (0.0.14) unstable; urgency=low
447
448   * Throw away any output from LVM commands while starting sysvms
449   * Correctly delete the lock LVs
450
451  -- Evan Broder <broder@mit.edu>  Mon, 10 Nov 2008 03:57:09 -0500
452
453 invirt-xen-config (0.0.13) unstable; urgency=low
454
455   * Use a lock LV when attempting to start sysvms since exclusive LV
456     activation has useless semantics
457
458  -- Evan Broder <broder@mit.edu>  Mon, 10 Nov 2008 03:15:31 -0500
459
460 invirt-xen-config (0.0.12) unstable; urgency=low
461
462   * Add missing close paren to init script
463
464  -- Evan Broder <broder@mit.edu>  Fri, 31 Oct 2008 09:50:47 -0400
465
466 invirt-xen-config (0.0.11) unstable; urgency=low
467
468   * Automatically startup sysvms if they're not running already
469
470  -- Evan Broder <broder@mit.edu>  Fri, 31 Oct 2008 09:47:15 -0400
471
472 invirt-xen-config (0.0.10) unstable; urgency=low
473
474   * Generate config files for sysvms
475
476  -- Evan Broder <broder@mit.edu>  Fri, 31 Oct 2008 07:40:13 -0400
477
478 invirt-xen-config (0.0.9) unstable; urgency=low
479
480   * don't try to disable tx checksums for HVMs; it errors out
481
482  -- Greg Price <price@mit.edu>  Wed, 29 Oct 2008 01:26:07 -0400
483
484 invirt-xen-config (0.0.8) unstable; urgency=low
485
486   * sipb-xen-base -> invirt-base
487
488  -- Evan Broder <broder@mit.edu>  Tue, 28 Oct 2008 04:23:38 -0400
489
490 invirt-xen-config (0.0.7) unstable; urgency=low
491
492   * Clarify description to distinguish from invirt-host-master
493
494  -- Greg Price <price@mit.edu>  Sat, 25 Oct 2008 21:16:51 -0400
495
496 invirt-xen-config (0.0.6) unstable; urgency=low
497
498   * sipb-xen-database-common -> invirt-database
499
500  -- Evan Broder <broder@mit.edu>  Sat, 25 Oct 2008 21:03:33 -0400
501
502 invirt-xen-config (0.0.5) unstable; urgency=low
503
504   * Give the init script a less weird sounding description
505
506  -- Evan Broder <broder@mit.edu>  Sat, 25 Oct 2008 19:11:28 -0400
507
508 invirt-xen-config (0.0.4) unstable; urgency=low
509
510   * Another typo in the init script
511
512  -- Evan Broder <broder@mit.edu>  Sat, 25 Oct 2008 19:07:32 -0400
513
514 invirt-xen-config (0.0.3) unstable; urgency=low
515
516   * Some small fixes in the init script
517
518  -- Evan Broder <broder@mit.edu>  Sat, 25 Oct 2008 19:03:12 -0400
519
520 invirt-xen-config (0.0.2) unstable; urgency=low
521
522   * Whoops - add the dependencies for the old sipb-xen-database-client
523
524  -- Evan Broder <broder@mit.edu>  Sat, 25 Oct 2008 18:38:56 -0400
525
526 invirt-xen-config (0.0.1) unstable; urgency=low
527
528   * Rename sipb-xen-dom0 -> invirt-xen-config
529   * Rearrange the source package
530   * Divert /etc/xen/qemu-ifup, since it existed and we've been scribbling
531     over it
532   * Generate /etc/xen/xend-config.sxp
533   * Move the invirt-database Xen config script into this package
534
535  -- Evan Broder <broder@mit.edu>  Sat, 25 Oct 2008 17:52:39 -0400
536
537 sipb-xen-dom0 (2.10) unstable; urgency=low
538
539   * Fix DHCP checksum error for ParaVMs
540
541  -- Evan Broder <broder@mit.edu>  Sun, 19 Oct 2008 22:12:09 -0400
542
543 sipb-xen-dom0 (2.9.1) unstable; urgency=low
544
545   * Whoops - was slightly too vicious with the cuts to qemu-dm-sipb
546
547  -- Evan Broder <broder@mit.edu>  Sun, 19 Oct 2008 01:55:41 -0400
548
549 sipb-xen-dom0 (2.9) unstable; urgency=low
550
551   * Move the qemu-ifup script to the location where it's now expected to
552     be.
553   * Clear out some debugging code from qemu-dm-sipb
554
555  -- Evan Broder <broder@mit.edu>  Sun, 19 Oct 2008 01:39:43 -0400
556
557 sipb-xen-dom0 (2.8) unstable; urgency=low
558
559   * Apply Sam's fix to vif-sipbroute for the prod cluster (the interface
560     should eventually be configurized)
561
562  -- Evan Broder <broder@mit.edu>  Tue, 07 Oct 2008 01:18:37 -0400
563
564 sipb-xen-dom0 (2.7) unstable; urgency=low
565
566   * Update qemu-dm-sipb to reflect the new location of qemu-dm
567
568  -- Evan Broder <broder@mit.edu>  Mon, 06 Oct 2008 18:55:59 -0400
569
570 sipb-xen-dom0 (2.6) unstable; urgency=low
571
572   * depend on sipb-xen-base
573
574  -- Greg Price <price@mit.edu>  Wed, 01 Oct 2008 20:28:21 -0400
575
576 sipb-xen-dom0 (2.5) unstable; urgency=low
577
578   * Don't rely on exported ROOT.
579
580  -- Anders Kaseorg <andersk@mit.edu>  Fri, 02 May 2008 02:41:43 -0400
581
582 sipb-xen-dom0 (2.4) unstable; urgency=low
583
584   * Add sipb-xen-losetup, a half-sane wrapper around the insane losetup.
585
586  -- Greg Price <price@mit.edu>  Thu,  1 May 2008 01:13:28 -0400
587
588 sipb-xen-dom0 (2.3) unstable; urgency=low
589
590   * Depend on generic metapackages/provides instead of particular 
591     versions.
592
593  -- Anders Kaseorg <andersk@sipb-xen.mit.edu>  Sat, 27 Oct 2007 21:23:00 -0400
594
595 sipb-xen-dom0 (2.2) unstable; urgency=low
596
597   * Add qemu-ifup script that depends on the device model script and
598     invokes vif-sipbroute.    As a consequence, we don't really support
599     bridged hvms any more.  It's not clear how to get enough information
600     out of qemu to do this.
601   * Call arpspoof with 18.181.0.1's address.  This is unfortunate in two
602     ways.  First, if we renumber we'll need to update the script.  Second,
603     it is possible that someone on 18.181 besides the router may have an
604     address cached.  Unfortunately, it doesn't work right if we don't
605     send the spoofed arp directly to the router.
606
607  -- Sam Hartman <hartmans@debian.org>  Sun, 26 Aug 2007 18:57:17 -0400
608
609 sipb-xen-dom0 (2.1) unstable; urgency=low
610
611   * Fix typo in init script 
612   * depend  on dsniff for arpspoof
613
614  -- Sam Hartman <hartmans@debian.org>  Fri, 24 Aug 2007 17:22:20 -0400
615
616 sipb-xen-dom0 (2) unstable; urgency=low
617
618   * Add qemu-dm-sipb written by andersk to get us the  domain ID in qemu-ifup 
619   * Add vif-sipbroute, a version of vif-route that does better netwwork
620     isolation and has initial but useless ipv6 support.  This version also
621     uses arpspoof to take over an address for domain migrations.   
622   * Add init script to enable rp_filter, proxy_arp and forwarding for the network config.
623
624  -- Sam Hartman <hartmans@debian.org>  Fri, 24 Aug 2007 17:17:23 -0400
625
626 sipb-xen-dom0 (1) unstable; urgency=low
627
628   *  First version
629
630  -- Sam Hartman <hartmans@debian.org>  Sat,  4 Aug 2007 20:20:32 -0400
631