Fix the installation of xvm-iscsi-config
[invirt/packages/xvm-iscsi-config.git] / debian / xvm-iscsi-config.postinst
index 7c743da..12226e3 100755 (executable)
@@ -20,6 +20,10 @@ set -e
 # for details, see http://www.debian.org/doc/debian-policy/ or
 # the debian-policy package
 
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
 
 case "$1" in
     configure)
@@ -29,6 +33,7 @@ case "$1" in
         USERNAME="$RET"
         db_get xvm-iscsi-config/password
         PASSWORD="$RET"
+        db_stop
         
         cat >/etc/invirt/conf.d/iscsi <<EOF
 iscsi:
@@ -50,9 +55,4 @@ EOF
     ;;
 esac
 
-# dh_installdeb will replace this with shell code automatically
-# generated by other debhelper scripts.
-
-#DEBHELPER#
-
 exit 0