Be more cautious about removing munin plugins
[invirt/packages/xvm-munin-config.git] / debian / xvm-munin-host-config.postinst
index 3dbbeb6..fc2de88 100755 (executable)
@@ -23,9 +23,6 @@ case "$1" in
         # So munin can read the mail log
         adduser munin adm
         
-        # First clear out the old stuff we threw in /etc/sudoers
-        perl -i.bak -ne 's%^### (BEGIN|END) xvm-munin-config\s*$%%m && ($skip = ($1 eq "BEGIN")); print unless $skip;' /etc/sudoers
-        
         # So munin can sudo to get to postfix queue info
         # and smartctl info
         # and info about running domains
@@ -39,6 +36,13 @@ EOF
         
         # Install munin plugins that are now configured
         munin-node-configure --suggest --shell | sh
+
+       (cd /etc/munin/plugins &&
+           for i in smart_*; do
+               if smartctl -i "/dev/${i#smart_}" | grep Device | grep EQLOGIC; then
+                   rm -v "$i";
+               fi
+           done)
         
         invoke-rc.d munin-node restart
     ;;