Correct the transformation script for lvm.conf
[invirt/packages/invirt-cluster-config.git] / debian / invirt-cluster-config.postinst
1 #!/bin/sh
2 # postinst script for #PACKAGE#
3 #
4 # see: dh_installdeb(1)
5
6 set -e
7
8 # summary of how this script can be called:
9 #        * <postinst> `configure' <most-recently-configured-version>
10 #        * <old-postinst> `abort-upgrade' <new version>
11 #        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12 #          <new-version>
13 #        * <postinst> `abort-remove'
14 #        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15 #          <failed-install-package> <version> `removing'
16 #          <conflicting-package> <version>
17 # for details, see http://www.debian.org/doc/debian-policy/ or
18 # the debian-policy package
19
20 # dh_installdeb will replace this with shell code automatically
21 # generated by other debhelper scripts.
22
23 #DEBHELPER#
24
25 case "$1" in
26     configure)
27         invoke-rc.d clvm stop
28         invoke-rc.d cman restart
29         invoke-rc.d clvm start
30     ;;
31
32     abort-upgrade|abort-remove|abort-deconfigure)
33     ;;
34
35     *)
36         echo "postinst called with unknown argument \`$1'" >&2
37         exit 1
38     ;;
39 esac
40
41 exit 0
42