2 # postinst script for #PACKAGE#
4 # see: dh_installdeb(1)
8 # summary of how this script can be called:
9 # * <postinst> `configure' <most-recently-configured-version>
10 # * <old-postinst> `abort-upgrade' <new version>
11 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
13 # * <postinst> `abort-remove'
14 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15 # <failed-install-package> <version> `removing'
16 # <conflicting-package> <version>
17 # for details, see http://www.debian.org/doc/debian-policy/ or
18 # the debian-policy package
20 # dh_installdeb will replace this with shell code automatically
21 # generated by other debhelper scripts.
22 # Note that by moving this above our generated code we could run into significant problems
23 # if we happened to start a daemon, and use debconf
24 # We move this up here because we need the diversion of postgresql.conf to happen before we create tables
31 #Don't create users on upgrade
33 # Don't fail if the user/database already exists
34 su postgres -c 'createuser sipb-xen -S -d -R' || true
35 su postgres -c 'createdb sipb_xen -O sipb-xen' || true
36 adduser --system sipb-xen
38 mako-render /etc/postgresql/8.1/main/pg_hba.conf.mako >/etc/postgresql/8.1/main/pg_hba.conf
39 /etc/init.d/postgresql-8.1 restart
40 su sipb-xen -s /bin/sh -c 'sipb-xen-database-tables create'
43 abort-upgrade|abort-remove|abort-deconfigure)
47 echo "postinst called with unknown argument \`$1'" >&2