3 DEB_DIVERT_EXTENSION = .invirt
4 DEB_DIVERT_FILES_invirt-ssh-config += \
5 /etc/ssh/sshd_config.invirt
7 include /usr/share/cdbs/1/rules/debhelper.mk
8 include /usr/share/cdbs/1/rules/config-package.mk
10 debian/sshd_config.invirt-orig: /var/lib/dpkg/info/openssh-server.postinst
11 perl -0pe 's/^.*<<EOF[^\n]*\n(.*\n)EOF\n.*$$/$$1/s or die;' $< > $@
13 common-build-indep:: debian/sshd_config.invirt
15 debian/sshd_config.invirt: debian/sshd_config.invirt-orig
17 s/^#?GSSAPIAuthentication .*$$/GSSAPIAuthentication yes\nGSSAPIKeyExchange yes\nGSSAPIStrictAcceptorCheck no/m and \
18 s/^#?GSSAPICleanupCredentials .*$$/GSSAPICleanupCredentials yes/m and \
19 s/^#?ChallengeResponseAuthentication .*$$/ChallengeResponseAuthentication yes/m and \
20 s/^#?UsePrivilegeSeparation .*$$/UsePrivilegeSeparation yes/m and \
21 s/^#?PasswordAuthentication .*$$/PasswordAuthentication no/m or die;' $< > $@
24 rm -f debian/sshd_config.invirt debian/sshd_config.invirt-orig