2 # postinst script for #PACKAGE#
4 # see: dh_installdeb(1)
8 # summary of how this script can be called:
9 # * <postinst> `configure' <most-recently-configured-version>
10 # * <old-postinst> `abort-upgrade' <new version>
11 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
13 # * <postinst> `abort-remove'
14 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15 # <failed-install-package> <version> `removing'
16 # <conflicting-package> <version>
17 # for details, see http://www.debian.org/doc/debian-policy/ or
18 # the debian-policy package
24 echo "Please be sure to copy vncproxy.crt and vncproxykey.pem into /usr/share/invirt-vnc-server/"
26 mkdir -p /etc/invirt/secrets
27 if ! [ -e /etc/invirt/secrets/vnc-key ]; then
28 openssl rand -base64 33 >/etc/invirt/secrets/vnc-key
32 abort-upgrade|abort-remove|abort-deconfigure)
36 echo "postinst called with unknown argument \`$1'" >&2
41 # dh_installdeb will replace this with shell code automatically
42 # generated by other debhelper scripts.