2 # postinst script for #PACKAGE#
4 # see: dh_installdeb(1)
8 # summary of how this script can be called:
9 # * <postinst> `configure' <most-recently-configured-version>
10 # * <old-postinst> `abort-upgrade' <new version>
11 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
13 # * <postinst> `abort-remove'
14 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15 # <failed-install-package> <version> `removing'
16 # <conflicting-package> <version>
17 # for details, see http://www.debian.org/doc/debian-policy/ or
18 # the debian-policy package
23 mkdir -p /etc/invirt/secrets
24 if ! [ -e /etc/invirt/secrets/vnc.pem ]; then
25 openssl genrsa -out /etc/invirt/secrets/vnc.pem 1024 >/dev/null
28 if ! [ -e /etc/invirt/secrets/vnc.crt ]; then
29 openssl req -new -x509 -nodes -sha1 -subj '/' -key /etc/invirt/secrets/vnc.pem \
30 > /etc/invirt/secrets/vnc.crt
33 if ! [ -e /etc/invirt/secrets/vnc-key ]; then
34 openssl rand -base64 33 >/etc/invirt/secrets/vnc-key
38 abort-upgrade|abort-remove|abort-deconfigure)
42 echo "postinst called with unknown argument \`$1'" >&2
47 # dh_installdeb will replace this with shell code automatically
48 # generated by other debhelper scripts.