2 # postinst script for xvm-iscsi-config
4 # see: dh_installdeb(1)
8 # Source debconf library
9 . /usr/share/debconf/confmodule
11 # summary of how this script can be called:
12 # * <postinst> `configure' <most-recently-configured-version>
13 # * <old-postinst> `abort-upgrade' <new version>
14 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
16 # * <postinst> `abort-remove'
17 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
18 # <failed-install-package> <version> `removing'
19 # <conflicting-package> <version>
20 # for details, see http://www.debian.org/doc/debian-policy/ or
21 # the debian-policy package
23 # dh_installdeb will replace this with shell code automatically
24 # generated by other debhelper scripts.
30 db_get xvm-iscsi-config/address
32 db_get xvm-iscsi-config/username
34 db_get xvm-iscsi-config/password
38 cat >/etc/invirt/conf.d/iscsi <<EOF
45 invoke-rc.d xvm-iscsi-config restart
46 invoke-rc.d open-iscsi restart
47 iscsiadm -m discovery -t st -p $(invirt-getconf iscsi.address):3260
49 # Don't disrupt an existing installation.
51 xvm-iscsi-config: If the configuration has changed, restart iscsi:
52 /etc/init.d/xvm-iscsi-config restart
53 /etc/init.d/open-iscsi restart
54 iscsiadm -m discovery -t st -p $(invirt-getconf iscsi.address):3260
55 lvchange -a ln /dev/xenvg && lvchange -a y /dev/xenvg
56 This will leave VMs unable to access their disks, so migrate them first.
62 abort-upgrade|abort-remove|abort-deconfigure)
66 echo "postinst called with unknown argument \`$1'" >&2