2 # postinst script for xvm-iscsi-config
4 # see: dh_installdeb(1)
8 # Source debconf library
9 . /usr/share/debconf/confmodule
11 # summary of how this script can be called:
12 # * <postinst> `configure' <most-recently-configured-version>
13 # * <old-postinst> `abort-upgrade' <new version>
14 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
16 # * <postinst> `abort-remove'
17 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
18 # <failed-install-package> <version> `removing'
19 # <conflicting-package> <version>
20 # for details, see http://www.debian.org/doc/debian-policy/ or
21 # the debian-policy package
23 # dh_installdeb will replace this with shell code automatically
24 # generated by other debhelper scripts.
30 db_get xvm-iscsi-config/address
32 db_get xvm-iscsi-config/username
34 db_get xvm-iscsi-config/password
38 if [ -e /etc/invirt/conf.d/iscsi ]; then
39 # invirt.config.run_parts_list excludes backup filenames.
40 mv -f /etc/invirt/conf.d/iscsi /etc/invirt/conf.d/iscsi~
42 cat >/etc/invirt/conf.d/iscsi <<EOF
49 invoke-rc.d xvm-iscsi-config restart
50 invoke-rc.d open-iscsi restart
51 iscsiadm -m discovery -t st -p $(invirt-getconf iscsi.address):3260
52 elif ! diff /etc/invirt/conf.d/iscsi~ /etc/invirt/conf.d/iscsi >/dev/null; then
54 xvm-iscsi-config: The configuration has changed. Restart iscsi:
55 /etc/init.d/xvm-iscsi-config restart
56 /etc/init.d/open-iscsi restart
57 iscsiadm -m discovery -t st -p $(invirt-getconf iscsi.address):3260
58 lvchange -a ln /dev/xenvg && lvchange -a y /dev/xenvg
59 This will leave VMs unable to access their disks, so migrate them first.
65 abort-upgrade|abort-remove|abort-deconfigure)
69 echo "postinst called with unknown argument \`$1'" >&2