Munin Xen CPU utilization fixes
[invirt/packages/xvm-munin-config.git] / debian / xvm-munin-host-config.postinst
1 #!/bin/sh
2 # postinst script for #PACKAGE#
3 #
4 # see: dh_installdeb(1)
5
6 set -e
7
8 # summary of how this script can be called:
9 #        * <postinst> `configure' <most-recently-configured-version>
10 #        * <old-postinst> `abort-upgrade' <new version>
11 #        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12 #          <new-version>
13 #        * <postinst> `abort-remove'
14 #        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15 #          <failed-install-package> <version> `removing'
16 #          <conflicting-package> <version>
17 # for details, see http://www.debian.org/doc/debian-policy/ or
18 # the debian-policy package
19
20
21 case "$1" in
22     configure)
23         # So munin can read the mail log
24         adduser munin adm
25         
26         # First clear out the old stuff we threw in /etc/sudoers
27         perl -i.bak -ne 's%^### (BEGIN|END) xvm-munin-config\s*$%%m && ($skip = ($1 eq "BEGIN")); print unless $skip;' /etc/sudoers
28         
29         # So munin can sudo to get to postfix queue info
30         # and smartctl info
31         # and info about running domains
32         cat >>/etc/sudoers <<EOF
33 ### BEGIN xvm-munin-config
34 munin ALL=(postfix) SETENV: NOPASSWD: /etc/munin/plugins/postfix_mailqueue
35 munin ALL=(munin) SETENV: NOPASSWD: ALL
36 munin ALL=(root) SETENV: NOPASSWD: /etc/munin/plugins/hddtemp_smartctl , /etc/munin/plugins/smart_* , /etc/munin/plugins/xen_cpu
37 ### END xvm-munin-config
38 EOF
39         
40         # Install munin plugins that are now configured
41         munin-node-configure --suggest --shell | sh
42         
43         invoke-rc.d munin-node restart
44     ;;
45
46     abort-upgrade|abort-remove|abort-deconfigure)
47     ;;
48
49     *)
50         echo "postinst called with unknown argument \`$1'" >&2
51         exit 1
52     ;;
53 esac
54
55 # dh_installdeb will replace this with shell code automatically
56 # generated by other debhelper scripts.
57
58 #DEBHELPER#
59
60 exit 0