2 # postinst script for #PACKAGE#
4 # see: dh_installdeb(1)
8 # summary of how this script can be called:
9 # * <postinst> `configure' <most-recently-configured-version>
10 # * <old-postinst> `abort-upgrade' <new version>
11 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
13 # * <postinst> `abort-remove'
14 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15 # <failed-install-package> <version> `removing'
16 # <conflicting-package> <version>
17 # for details, see http://www.debian.org/doc/debian-policy/ or
18 # the debian-policy package
23 # So munin can read the mail log
26 # So munin can sudo to get to postfix queue info
27 cat >>/etc/sudoers <<EOF
28 ### BEGIN xvm-munin-config
29 munin ALL=(postfix) SETENV: NOPASSWD: /etc/munin/plugins/postfix_mailqueue
30 munin ALL=(munin) SETENV: NOPASSWD: ALL
31 ### END xvm-munin-config
34 # Install munin plugins that are now configured
35 munin-node-configure --suggest --shell | sh
37 invoke-rc.d munin-node restart
40 abort-upgrade|abort-remove|abort-deconfigure)
44 echo "postinst called with unknown argument \`$1'" >&2
49 # dh_installdeb will replace this with shell code automatically
50 # generated by other debhelper scripts.