2 # postinst script for #PACKAGE#
4 # see: dh_installdeb(1)
8 # summary of how this script can be called:
9 # * <postinst> `configure' <most-recently-configured-version>
10 # * <old-postinst> `abort-upgrade' <new version>
11 # * <conflictor's-postinst> `abort-remove' `in-favour' <package>
13 # * <postinst> `abort-remove'
14 # * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15 # <failed-install-package> <version> `removing'
16 # <conflicting-package> <version>
17 # for details, see http://www.debian.org/doc/debian-policy/ or
18 # the debian-policy package
23 # So munin can read the mail log
26 # First clear out the old stuff we threw in /etc/sudoers
27 perl -i.bak -ne 's%^### (BEGIN|END) xvm-munin-config\s*$%%m && ($skip = ($1 eq "BEGIN")); print unless $skip;' /etc/sudoers
29 # So munin can sudo to get to postfix queue info
30 cat >>/etc/sudoers <<EOF
31 ### BEGIN xvm-munin-config
32 munin ALL=(postfix) SETENV: NOPASSWD: /etc/munin/plugins/postfix_mailqueue
33 munin ALL=(munin) SETENV: NOPASSWD: ALL
34 ### END xvm-munin-config
37 # So munin can read from the database
38 su postgres -c 'createuser -S -D -R munin' || true
39 su postgres -c 'psql invirt --quiet' <<EOF
40 GRANT SELECT ON pg_class TO munin;
41 GRANT SELECT ON pg_index TO munin;
42 GRANT SELECT ON pg_statio_user_tables TO munin;
43 GRANT SELECT ON pg_stat_activity TO munin;
44 GRANT SELECT ON pg_locks TO munin;
47 # Install munin plugins that are now configured
48 munin-node-configure --suggest --shell | sh
50 invoke-rc.d munin-node restart
53 abort-upgrade|abort-remove|abort-deconfigure)
57 echo "postinst called with unknown argument \`$1'" >&2
62 # dh_installdeb will replace this with shell code automatically
63 # generated by other debhelper scripts.