Fix-up several packages to include the correct Conflicts and Replaces
[invirt/packages/xvm-munin-config.git] / debian / xvm-munin-host-config.postinst
1 #!/bin/sh
2 # postinst script for #PACKAGE#
3 #
4 # see: dh_installdeb(1)
5
6 set -e
7
8 # summary of how this script can be called:
9 #        * <postinst> `configure' <most-recently-configured-version>
10 #        * <old-postinst> `abort-upgrade' <new version>
11 #        * <conflictor's-postinst> `abort-remove' `in-favour' <package>
12 #          <new-version>
13 #        * <postinst> `abort-remove'
14 #        * <deconfigured's-postinst> `abort-deconfigure' `in-favour'
15 #          <failed-install-package> <version> `removing'
16 #          <conflicting-package> <version>
17 # for details, see http://www.debian.org/doc/debian-policy/ or
18 # the debian-policy package
19
20
21 case "$1" in
22     configure)
23         # So munin can read the mail log
24         adduser munin adm
25         
26         # So munin can sudo to get to postfix queue info
27         # and smartctl info
28         # and info about running domains
29         cat >>/etc/sudoers <<EOF
30 ### BEGIN xvm-munin-config
31 munin ALL=(postfix) SETENV: NOPASSWD: /etc/munin/plugins/postfix_mailqueue
32 munin ALL=(munin) SETENV: NOPASSWD: ALL
33 munin ALL=(root) SETENV: NOPASSWD: /etc/munin/plugins/hddtemp_smartctl , /etc/munin/plugins/smart_* , /etc/munin/plugins/xen_cpu
34 ### END xvm-munin-config
35 EOF
36         
37         # Install munin plugins that are now configured
38         munin-node-configure --suggest --shell | sh
39         
40         invoke-rc.d munin-node restart
41     ;;
42
43     abort-upgrade|abort-remove|abort-deconfigure)
44     ;;
45
46     *)
47         echo "postinst called with unknown argument \`$1'" >&2
48         exit 1
49     ;;
50 esac
51
52 # dh_installdeb will replace this with shell code automatically
53 # generated by other debhelper scripts.
54
55 #DEBHELPER#
56
57 exit 0